Drupal Core is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Drupal Core versions 6.x ranging from 6.0 and up to and including 6.20 are vulnerable.
Update to Drupal Core version 6.21 or latest