Drupal Core 6.x Multiple Vulnerabilities (6.0 - 6.37)

Description

Drupal Core is prone to multiple vulnerabilities, including security bypass, open redirect, reflected file download, brute force amplification or HTTP header injection vulnerabilities. Exploiting these issues could allow an attacker to perform otherwise restricted actions and subsequently submit input using JavaScript or gain all roles on a site, to redirect users to arbitrary web sites and conduct phishing attacks, to trick a user into downloading and running a file with arbitrary JSON-encoded content, to determine user passwords by submitting a large number of password variations at once or to set arbitrary headers of their own choosing, which may help in launching further attacks. Drupal Core versions 6.x ranging from 6.0 and up to and including 6.37 are vulnerable.

Remediation

Update to Drupal Core version 6.38 or latest

References