Description
Drupal Core is prone to a security bypass vulnerability. Exploiting this issue may allow attackers to perform otherwise restricted actions and subsequently list all nodes. Drupal Core versions 7.x ranging from 7.0 and up to and including 7.2 are vulnerable.
Remediation
Update to Drupal Core version 7.3 or latest
References
Related Vulnerabilities
WordPress Plugin WP Mobile Detector Multiple Vulnerabilities (3.8)
TYPO3 Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2009-0815)
WordPress Plugin MathJax-LaTeX Cross-Site Request Forgery (1.1)
WordPress Plugin Booking Calendar Contact Form Multiple Vulnerabilities (1.0.2)