Description
Drupal Core is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Drupal Core versions 9.0.x ranging from 9.0.0 and up to and including 9.0.5 are vulnerable.
Remediation
Update to Drupal Core version 9.0.6 or latest
References
Related Vulnerabilities
IBM WebSEAL Use of a Broken or Risky Cryptographic Algorithm Vulnerability (CVE-2019-4156)
MySQL CVE-2022-39410 Vulnerability (CVE-2022-39410)
Apache HTTP Server Incorrect Check of Function Return Value Vulnerability (CVE-2025-54090)
Apache Tomcat Permissions, Privileges, and Access Controls Vulnerability (CVE-2014-0119)