Description
Drupal Core is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Drupal Core versions ranging from 8.0.0 and up to and including 9.1.15 are vulnerable.
Remediation
Update to Drupal Core version 9.2.11 or latest
References
https://www.drupal.org/sa-core-2022-001
https://github.com/jquery/jquery-ui/security/advisories/GHSA-gpqq-952q-5327
Related Vulnerabilities
Jboss EAP Deserialization of Untrusted Data Vulnerability (CVE-2018-12022)
WordPress Plugin WP DS FAQ Plus Cross-Site Scripting (1.4.1)
WordPress Plugin WordPress Facebook Multiple Cross-Site Scripting Vulnerabilities (1.0.10)
WordPress Plugin WordPress Button Plugin MaxButtons Security Bypass (1.19.0)