Description
If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Remediation
References
Related Vulnerabilities
WordPress Plugin Visual CSS Style Editor Cross-Site Request Forgery (7.2.0)
PHP Other Vulnerability (CVE-2007-1890)
IBM RTC Server-Side Request Forgery (SSRF) Vulnerability (CVE-2020-4974)
MySQL Improper Validation of Array Index Vulnerability (CVE-2022-21310)
WordPress Plugin Enable Media Replace SQL Injection and Arbitrary File Upload Vulnerabilities (2.3)