Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
Remediation
References
Related Vulnerabilities
Drupal CVE-2017-6930 Vulnerability (CVE-2017-6930)
XWikiplatform Insufficient UI Warning of Dangerous Operations Vulnerability (CVE-2025-49585)
MediaWiki Observable Differences in Behavior to Error Inputs Vulnerability (CVE-2020-35624)
WordPress Plugin SupportCandy Arbitrary File Upload (2.0.0)
WordPress Plugin IGIT Posts Slider Widget TimThumb Arbitrary File Upload (1.1)