RCE with Spring Data Commons

Description
  • Spring Data Commons, versions prior to 1.13 to 1.13.10, 2.0 to 2.0.5, and older unsupported versions, contain a property binder vulnerability caused by improper neutralization of special elements. An unauthenticated remote malicious user (or attacker) can supply specially crafted request parameters against Spring Data REST backed HTTP resources or using Spring Data's projection-based request payload binding hat can lead to a remote code execution attack.
Remediation
  • Users of affected versions should apply the following mitigation:

    • 2.0.x users should upgrade to 2.0.6
    • 1.13.x users should upgrade to 1.13.11
    • Older versions should upgrade to a supported branch
References