Description
WordPress is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks. WordPress versions prior to 2.8.2 are vulnerable.
Remediation
Update to WordPress version 2.8.2 or latest
References
http://www.exploit-db.com/exploits/9250/
http://packetstormsecurity.org/files/view/79605/wp281-xss.txt
http://www.securityfocus.com/bid/35797/exploit
Related Vulnerabilities
WordPress 3.9.x Multiple Vulnerabilities (3.9 - 3.9.12)
WordPress Plugin Ultimate Membership Pro SQL Injection (6.4)
Moodle Permissions, Privileges, and Access Controls Vulnerability (CVE-2008-6125)
Oracle Database Server CVE-2014-4236 Vulnerability (CVE-2014-4236)
WordPress Plugin GiveWP-Donation and Fundraising Platform Cross-Site Scripting (0.8)