WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. WordPress versions prior to 3.0.4 are vulnerable.
Update to WordPress version 3.0.4 or latest
WordPress 3.8.4 Multiple Vulnerabilities (3.8 - 3.8.4)
WordPress Plugin HD Webplayer Multiple SQL Injection Vulnerabilities (1.1)
WordPress Plugin Recent Backups Arbitrary File Download (0.7)
WordPress Plugin Name Directory Cross-Site Request Forgery (1.17.4)