Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, open redirect and security bypass vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, to redirect users to arbitrary web sites and conduct phishing attacks, or to bypass certain security restrictions and perform unauthorized actions. WordPress versions 4.0.x ranging from 4.0 and up to (and including) 4.0.30 are vulnerable.
Remediation
Update to WordPress version 4.0.31 or latest
References
https://pentest.co.uk/labs/research/subtle-stored-xss-wordpress-core/
https://www.youtube.com/watch?v=tCh7Y8z8fb4
https://wordpress.org/support/wordpress-version/version-4-0-31/
Related Vulnerabilities
WordPress 4.2.x Cross-Site Scripting Vulnerability (4.2 - 4.2.5)
WordPress Plugin Gmail SMTP Arbitrary File Disclosure (1.1.0)
phpMyFAQ Cross-Site Request Forgery (CSRF) Vulnerability (CVE-2014-0813)
ownCloud Other Vulnerability (CVE-2015-5954)
WordPress Plugin Click to Call or Chat Buttons Cross-Site Scripting (1.4.0)