Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, directory traversal and open redirect vulnerabilities because it fails to properly sanitize/verify user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, to steal cookie-based authentication credentials, to obtain sensitive information that could aid in further attacks, or to redirect users to arbitrary web sites and conduct phishing attacks. WordPress versions 4.2.x ranging from 4.2 and up to (and including) 4.2.15 are vulnerable.
Remediation
Update to WordPress version 4.2.16 or latest
References
https://medium.com/websec/wordpress-sqli-bbb2afcc8e94
https://medium.com/websec/wordpress-sqli-poc-f1827c20bf8e
https://blog.sucuri.net/2017/09/stored-cross-site-scripting-vulnerability-in-wordpress-4-8-1.html
Related Vulnerabilities
PHP-Fusion Permissions, Privileges, and Access Controls Vulnerability (CVE-2013-1807)
WordPress Plugin Ultimate Tag Cloud Widget Unspecified Vulnerability (2.3)
WordPress Plugin Mobile browser color select Cross-Site Request Forgery (1.0.1)
SugarCRM Improper Control of Generation of Code ('Code Injection') Vulnerability (CVE-2019-17310)
Jetty Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2015-2080)