Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, cross-site request forgery, open redirect, information disclosure and SQL injection vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, to perform certain administrative actions and gain unauthorized access to the affected application, to redirect users to arbitrary web sites and conduct phishing attacks, to obtain potentially sensitive information or to compromise the application, access or modify data or exploit vulnerabilities in the underlying database. WordPress versions 4.2.x ranging from 4.2 and up to (and including) 4.2.33 are vulnerable.
Remediation
Update to WordPress version 4.2.34 or latest
References
Related Vulnerabilities
ReviveAdserver Cross-Site Request Forgery (CSRF) Vulnerability (CVE-2015-7366)
WordPress 4.4.x Multiple Vulnerabilities (4.4 - 4.4.3)
WordPress Plugin Gallery-Video Gallery and Youtube Gallery Cross-Site Scripting (1.7.01)
SharePoint CVE-2021-34517 Vulnerability (CVE-2021-34517)
Oracle Application Server CVE-2006-3707 Vulnerability (CVE-2006-3707)