Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, security bypass, or server-side request forgery vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, to bypass certain security restrictions and perform unauthorized actions, or to make the vulnerable server perform port scanning of hosts in internal or external networks. WordPress versions 4.3.x ranging from 4.3 and up to (and including) 4.3.20 are vulnerable.
Remediation
Update to WordPress version 4.3.21 or latest
References
https://0day.work/proof-of-concept-for-wordpress-5-2-3-viewing-unauthenticated-posts/
https://blog.ripstech.com/2020/wordpress-hardening-bypass/
https://wordpress.org/support/wordpress-version/version-4-3-21/
Related Vulnerabilities
WordPress Plugin UserPro-Community and User Profile Cross-Site Scripting (4.9.33)
Plone CMS Permissions, Privileges, and Access Controls Vulnerability (CVE-2012-5489)
OpenSSL Cryptographic Issues Vulnerability (CVE-2008-7270)
Django Allocation of Resources Without Limits or Throttling Vulnerability (CVE-2024-53907)