Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, security bypass, information disclosure and PHP object injection vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform otherwise restricted actions and subsequently delete files that they weren't authorized to or create posts of unauthorized post types, to obtain sensitive information, or to possibly execute arbitrary PHP code within the context of the affected webserver process. WordPress versions 4.7.x ranging from 4.7 and up to (and including) 4.7.11 are vulnerable.
Remediation
Update to WordPress version 4.7.12 or latest
References
https://blog.ripstech.com/2018/wordpress-post-type-privilege-escalation/
https://blog.ripstech.com/2019/wordpress-image-remote-code-execution/
http://foreversong.cn/archives/1364
https://wordpress.org/support/wordpress-version/version-4-7-12/
Related Vulnerabilities
Jenkins Improper Restriction of Rendered UI Layers or Frames Vulnerability (CVE-2020-2105)
WordPress Plugin WP eCommerce SQL Injection (3.11.3)
WordPress Plugin Delete All Comments Cross-Site Request Forgery (1.0)
WordPress Plugin Stock Ticker Security Bypass (3.23.0)
WordPress Plugin WpPygments Multiple Cross-Site Scripting Vulnerabilities (0.3.2)