Description
WordPress is prone to a cross-site request forgery vulnerability. Exploiting this issue may allow a remote attacker to perform certain administrative actions and gain unauthorized access to the affected application; other attacks are also possible. WordPress versions 5.0.x ranging from 5.0 and up to (and including) 5.0.3 are vulnerable.
Remediation
Update to WordPress version 5.0.4 or latest
References
https://blog.ripstech.com/2019/wordpress-csrf-to-rce/
https://cert.360.cn/warning/detail?id=149a32b8f582ee5e0cbd5f1c1b4a61de
https://wordpress.org/support/wordpress-version/version-5-0-4/
Related Vulnerabilities
PostgreSQL Other Vulnerability (CVE-2003-0901)
OpenSSL Observable Differences in Behavior to Error Inputs Vulnerability (CVE-2019-1559)
PHP Missing Release of Resource after Effective Lifetime Vulnerability (CVE-2010-4657)
Drupal Improper Control of Dynamically-Managed Code Resources Vulnerability (CVE-2025-31674)
Magento Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2016-2212)