Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting and security bypass vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, or to bypass certain security restrictions and perform unauthorized actions. WordPress versions 5.1.x ranging from 5.1 and up to (and including) 5.1.3 are vulnerable.
Remediation
Update to WordPress version 5.1.4 or latest
References
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-g7rg-hchx-c2gw
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-pg4x-64rh-3c9v
https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-x3wp-h3qx-9w94
https://wordpress.org/support/wordpress-version/version-5-1-4/
Related Vulnerabilities
Magento Improper Control of Generation of Code ('Code Injection') Vulnerability (CVE-2019-7903)
WordPress Plugin Wechat Broadcast Local/Remote File Inclusion (1.2.0)
WordPress Plugin SEO Redirection-301 Redirect Manager Cross-Site Request Forgery (7.8)
Apache HTTP Server Server-Side Request Forgery (SSRF) Vulnerability (CVE-2021-40438)