Description
WordPress is prone to multiple vulnerabilities, including XML External Entity injection and information disclosure vulnerabilities. Exploiting these issues could allow an attacker to obtain sensitive information which could be used to launch further attacks. WordPress versions 5.4.x ranging from 5.4 and up to (and including) 5.4.4 are vulnerable.
Remediation
Update to WordPress version 5.4.5 or latest
References
https://blog.sonarsource.com/wordpress-xxe-security-vulnerability/
https://github.com/motikan2010/CVE-2021-29447
https://wordpress.org/support/wordpress-version/version-5-4-5/
Related Vulnerabilities
Plone CMS Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2013-4194)
WordPress Plugin Great Quotes Cross-Site Scripting (1.0.0)
Internet Information Services CVE-2002-1790 Vulnerability (CVE-2002-1790)
WordPress Plugin WordPress Landing Pages Cross-Site Scripting (1.8.5)