Description
WordPress is prone to multiple SQL injection vulnerabilities because it fails to sufficiently sanitize user-supplied data before using it in an SQL query. Exploiting these issues could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. WordPress versions prior to 0.72 are vulnerable.
Remediation
Update to WordPress version 0.72 or latest
References
http://www.securityfocus.com/bid/8756/exploit
http://www.securityfocus.com/archive/1/340113
http://archives.neohapsis.com/archives/bugtraq/2003-10/0032.html
Related Vulnerabilities
Drupal Core 8.x.x Cross-Site Request Forgery (8.0.0 - 8.8.12)
WordPress Plugin Site Offline Or Coming Soon Or Maintenance Mode Cross-Site Request Forgery (1.4.3)
Jenkins Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2017-2603)
XWiki Improper Control of Generation of Code ('Code Injection') Vulnerability (CVE-2023-29214)
ownCloud Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2017-5865)