Description
WordPress is prone to a cross-site request forgery vulnerability. Exploiting this issue may allow a remote attacker to perform certain administrative actions and gain unauthorized access to the affected application; other attacks are also possible. WordPress versions ranging from 0.70 and up to (and including) 3.6.1 are vulnerable.
Remediation
Update to WordPress version 5.1.1 or latest
References
https://blog.ripstech.com/2019/wordpress-csrf-to-rce/
https://cert.360.cn/warning/detail?id=149a32b8f582ee5e0cbd5f1c1b4a61de
https://wordpress.org/news/2019/03/wordpress-5-1-1-security-and-maintenance-release/
Related Vulnerabilities
XWikiplatform CVE-2025-48063 Vulnerability (CVE-2025-48063)
MongoDb Improper Validation of Specified Type of Input Vulnerability (CVE-2026-9742)
WebLogic CVE-2016-3586 Vulnerability (CVE-2016-3586)
Apache HTTP Server Cross-Site Request Forgery (CSRF) Vulnerability (CVE-2007-6420)
Handlebars Improper Control of Generation of Code ('Code Injection') Vulnerability (CVE-2026-33938)