Description
WordPress Plugin Bad Behavior is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. WordPress Plugin Bad Behavior versions 2.2.x before 2.2.5 and 2.0.x before 2.0.47 are vulnerable.
Remediation
Update to plugin versions 2.2.5 or 2.0.47 or latest
References
Related Vulnerabilities
WordPress Plugin YAWPP (Yet Another WordPress Petition Plugin) SQL Injection (1.2)
WordPress Plugin Rezgo Online Booking Cross-Site Scripting (4.1.7)
WordPress Plugin Popup Maker-Popup for opt-ins, lead gen, & more Security Bypass (1.7.29)
WordPress Plugin DM Albums Multiple File Deletion Vulnerabilities (2.1)
WordPress Plugin Slider Revolution Responsive Arbitrary File Upload (3.0.95)