Description
WordPress Plugin WP-Syntax is prone to a vulnerability that lets remote attackers execute arbitrary code because the application fails to sanitize user-supplied input. Attackers can exploit this issue to execute arbitrary PHP code within the context of the affected webserver process. WordPress Plugin WP-Syntax versions 0.9.9 and prior are affected.
Remediation
Update to plugin version 0.9.10 or latest
References
Related Vulnerabilities
WordPress Plugin CopySafe PDF Protection Arbitrary File Upload (0.6)
Moodle Incorrect Authorization Vulnerability (CVE-2024-48901)
PHP Improper Input Validation Vulnerability (CVE-2011-4153)
Jboss EAP Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2014-3481)
PHP Permissions, Privileges, and Access Controls Vulnerability (CVE-2015-2348)