- WordPress is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks. WordPress versions prior to 2.6 are vulnerable.
- Update to WordPress version 2.6 or latest
- WordPress Plugin WPML (WordPress Multilingual) Cross-Site Scripting (3.2.6)
- WordPress Plugin Chunks Cross-Site Scripting (1.1)
- WordPress Plugin User Access Manager Cross-Site Scripting (126.96.36.199)
- WordPress Plugin Alert Before Your Post Cross-Site Scripting (0.1.1)
- WordPress Multiple Cross-Site Scripting and SQL Injection Vulnerabilities (1.2.1 - 1.2.2)