Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Remediation
References
https://lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo
https://security.netapp.com/advisory/ntap-20220715-0007/
Related Vulnerabilities
CVE-2019-3888 Vulnerability in maven package io.undertow:undertow-core
CVE-2019-18394 Vulnerability in maven package org.igniterealtime.openfire:xmppserver
CVE-2021-21292 Vulnerability in maven package org.traccar:traccar
CVE-2022-23596 Vulnerability in maven package com.github.junrar:junrar
CVE-2019-10319 Vulnerability in maven package org.jenkins-ci.plugins:pam-auth