Description
Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.
Remediation
References
Related Vulnerabilities
WordPress Plugin Translate WordPress with GTranslate Open Redirect (2.8.10)
axios Improper Check for Unusual or Exceptional Conditions Vulnerability (CVE-2026-25639)
WordPress Plugin Pinterest Badge Cross-Site Scripting (1.9.0)
WordPress 3.8.x Cross-Site Scripting Vulnerability (3.8 - 3.8.11)
WordPress Plugin WPML (WordPress Multilingual) Cross-Site Scripting (3.2.6)