Description
In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.
Remediation
References
Related Vulnerabilities
Moodle Permissions, Privileges, and Access Controls Vulnerability (CVE-2008-6125)
WordPress Plugin Facebook Like Box Unspecified Vulnerability (1.0.17)
WordPress Plugin Content Blocks (Custom Post Widget) Local File Inclusion (3.3.0)
Drupal Other Vulnerability (CVE-2005-0682)
Oracle Database Server CVE-2007-5530 Vulnerability (CVE-2007-5530)