Joomla! Core is prone to a security bypass vulnerability. Exploiting this issue may allow attackers to perform otherwise restricted actions and subsequently delete private messages. Joomla! Core versions 3.0.x ranging from 3.0.0 and up to and including 3.0.3 are vulnerable.
Update to Joomla! Core version 3.0.4 or latest