Joomla! Core is prone to multiple vulnerabilities, including cross-site scripting and information disclosure vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, or to obtain sensitive information that may help in launching further attacks. Joomla! Core versions 4.x.x ranging from 4.0.0 and up to and including 4.2.3 are vulnerable.
Update to Joomla! Core version 4.2.4 or latest