Description
Next.js versions >=9.5.0 and <9.5.4 are vulnerable to an Open Redirect. Specially encoded paths could be used with the trailing slash redirect to allow an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attackers domain from a trusted domain. The issue is fixed in version 9.5.4.
Remediation
References
Related Vulnerabilities
EspoCRM Relative Path Traversal Vulnerability (CVE-2026-33733)
WordPress Plugin WP Inimat Cross-Site Scripting (1.0)
WordPress Plugin Spam protection, AntiSpam, FireWall by CleanTalk Cross-Site Scripting (5.127.3)
MySQL CVE-2025-50083 Vulnerability (CVE-2025-50083)
Apache HTTP Server NULL Pointer Dereference Vulnerability (CVE-2017-7659)