WordPress is prone to multiple SQL injection vulnerabilities because it fails to sufficiently sanitize user supplied data before using it in an SQL query. Exploiting these issues could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. WordPress versions prior to 3.1.4 are vulnerable.
Update to WordPress version 3.1.4 or latest
WordPress 4.7.x Denial of Service Vulnerability (4.7 - 4.7.9)
WordPress Plugin Import all XML, CSV & TXT into WordPress Security Bypass (6.4.1)
WordPress Plugin Adminer Multiple Cross-Site Scripting Vulnerabilities (1.4.3)