Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, directory traversal and open redirect vulnerabilities because it fails to properly sanitize/verify user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, to steal cookie-based authentication credentials, to obtain sensitive information that could aid in further attacks, or to redirect users to arbitrary web sites and conduct phishing attacks. WordPress versions 4.6.x ranging from 4.6 and up to (and including) 4.6.6 are vulnerable.
Remediation
Update to WordPress version 4.6.7 or latest
References
https://medium.com/websec/wordpress-sqli-bbb2afcc8e94
https://medium.com/websec/wordpress-sqli-poc-f1827c20bf8e
https://blog.sucuri.net/2017/09/stored-cross-site-scripting-vulnerability-in-wordpress-4-8-1.html
Related Vulnerabilities
WordPress Plugin Real WYSIWYG 'insert_file.php' Arbitrary File Upload (0.0.2)
MediaWiki Cross-Site Request Forgery (CSRF) Vulnerability (CVE-2012-1580)
Grafana Server-Side Request Forgery (SSRF) Vulnerability (CVE-2020-13379)
Jboss EAP Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2015-1849)