Description
WordPress is prone to multiple vulnerabilities, including XML External Entity injection and information disclosure vulnerabilities. Exploiting these issues could allow an attacker to obtain sensitive information which could be used to launch further attacks. WordPress versions 5.1.x ranging from 5.1 and up to (and including) 5.1.8 are vulnerable.
Remediation
Update to WordPress version 5.1.9 or latest
References
https://blog.sonarsource.com/wordpress-xxe-security-vulnerability/
https://github.com/motikan2010/CVE-2021-29447
https://wordpress.org/support/wordpress-version/version-5-1-9/
Related Vulnerabilities
WordPress Plugin Site Reviews Multiple Vulnerabilities (6.5.1)
WordPress Plugin Duplicator-WordPress Migration Security Bypass (0.5.8)
Craft CMS Improper Authentication Vulnerability (CVE-2024-41800)
MySQL CVE-2018-2777 Vulnerability (CVE-2018-2777)
WordPress Plugin Drag & Drop File Uploader 'dnd-upload.php' Arbitrary File Upload (0.1)