Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting and SQL injection vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, or to compromise the application, access or modify data or exploit vulnerabilities in the underlying database. WordPress versions 5.9.x ranging from 5.9 and up to (and including) 5.9.3 are vulnerable.
Remediation
Update to WordPress version 5.9.4 or latest
References
Related Vulnerabilities
WordPress Plugin WP Maps-Display Google Maps Perfectly with Ease SQL Injection (4.1.4)
IBM RTC Exposure of Sensitive Information to an Unauthorized Actor Vulnerability (CVE-2018-1423)
Apache Tomcat Improper Encoding or Escaping of Output Vulnerability (CVE-2025-31651)
PHP Integer Overflow or Wraparound Vulnerability (CVE-2025-14178)