Description
WordPress Plugin Quiz and Survey Master (QSM)-Easy Quiz and Survey Maker is prone to an SQL injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query. Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. WordPress Plugin Quiz and Survey Master (QSM)-Easy Quiz and Survey Maker version 9.0.1 is vulnerable; prior versions may also be affected.
Remediation
Update to plugin version 9.0.2 or latest
References
Related Vulnerabilities
MySQL CVE-2021-2217 Vulnerability (CVE-2021-2217)
WordPress Plugin WordPress Backup to Dropbox Information Disclosure (4.7.1)
WordPress Plugin Properties and Agents-Real Estate Manager Cross-Site Scripting (6.7.1)
Django Use of Cache Containing Sensitive Information Vulnerability (CVE-2026-35193)
Joomla Cross-Site Request Forgery (CSRF) Vulnerability (CVE-2020-8420)